Edit Menu

The Edit menu includes items for editing your score.

The Set Voice menu item shifts the voice number of selected notes to one of the 3 voices set in the NoteAbility Score Controls. The 3 voices allowed for each staff in NoteAbility are: The Jump Back menu item causes the Entry Cursor to move back to its previous position. This menu is normally activated through the Command short-cut: Command-g.

The Select Page menu item selects all images on the current page. The selection is done by creating a seleciton rectangle the size of the entire page. This menu item followed by Copy All Types menu ittem can be used to quickly copy and paste a score page into another document as a TIFF or PDF image.

The Select Document menu item selects all images on all pages of the document. This operation can be used for performing global operations on the entire document (such as changing the size of all images on the document) or for copying the entire score for pasting into a new document.

The Select Next Image menu item highlighs the next image in a previously selected passage and enables editing for that image. To use this menu item, select an area of the score, then use this menu item (or the shortcut Control-right arrow key) to move through the selected images one-by-one. As each image becomes selected, you can perform other editing operations on it, before moving to the next image.

The Change Staff menu item is used to change the staff association of selected images to the staff ID that the Entry Cursor is on. This menu item should only be used if you discover that an image is associated with the wrong staff and therefore is not adjusting its position when the staff is adjusted. This operation can be used for dynamic marks, text, slurs, graphics, etc. but not normally for notes since ledger lines will be drawn to the new staff and the pitches will now be incorrect:

When the staff association is changed, the relative voice number is retained - if an image was in the second voice on staff ID 2 and it is changed to staff ID 1, it will now be on the second voice of staff ID 1.

Undo

The Undo operation (Command-z) reverts the document to its state before the last image was added or the last editing change was made. Multiple levels of Undo are available in NoteAbility, so you can walk back through the history of the changes to your document. Although most editing operations can be reversed with undo, many formatting operations cannot. The last operation that can be reversed with undo is displayed in a text field at the bottom of the score window.

Before performing an Undo, check that the Undo Display is showing the change to the document that you want to undo.

Redo

The Redo operation (Command-Z) reverts the document to its state before the last Undo was performed. Redo can only be performed after undo (or after a series of undos). Once a new change has been made to the document, you cannot redo any previous undos. The bottom of each score window has an Undo button (left arrow) and a Redo button (right arrow) which can be used instead of the menu items or menu shortcuts:

The Previous Page and Next Page menu items are short cuts for changing pages in the front-most score. Changing pages can also be done by clicking on the Page arrows in the Control panel.

The Spelling sub-menu is part of the Macintosh OS-X environment, and may change with different versions of the operating system. Currently there are three items in the Spelling sub-menu operation:

See also

© Keith A. Hamel 1998-2005 - All Rights Reserved