File Menu

The File menu includes items for opening, saving, printing and playing documents.

The Open Recent menu item displays a sub-menu listing some of the recently edited NoteAbilityPro documents. You can open any one of these files by selecting it with the cursor (while the mouse button is still depressed.) The Open Recent sub-menu also includes a Clear Menu item which (when selected) clears the list of recent documents from this menu.

The Revert To Saved menu item replaces the current document with the copy of the document that was last saved on disk. A warning panel will appear to ensure that you want to remove all the changes you have made since the file was last saved.

The Restore Auto Saved Files menu item allows you to open documents that have been saved onto your hard drive with NoteAbilityPro's auto save feature. If the Auto-save feature is enabled in the NoteAbilityPro Preference panel (Other tab), all opened files are saved periodically into a temporary file location. After a software crash, it is possible to use this menu item to open any files that have been "auto-saved" since the last time the computer was restarted. Files are stored in your computer's /tmp folder. Once a file has been restored, you should save it into your a new location on your hard drive.

The Import Guido... menu item brings us the standard Open.. dialog box and allows you to import a text file in GUIDO Music Notation format. If the document layout information is included in the GUIDO file, then a new document will be created. If you are importanting incomplete GUIDO data, you should select and paste the GUIDO data into an existing NoteAbilityPro document -- the imported GUIDO code will be pasted beginning at the Entry Cursor position.

The MusicXML menu item has a submenu which allows you to import and export MusicXML files. This file format is used to transfer between NoteAbilityPro and other music application such as Finale and Sibelius. Imported MusicXML files should have the extension .xml.

The NAPro-IPad menu item has a submenu which allows you to import and export scores to the iPad version of NoteAbilityPro. NAPro-iPad files have the extension .nap and are completely compatible with .na files, so that files can be transferred back and forth between the two environments.

The Import NoteWriter... menu item brings up the standard Open panel and allows you to import a NoteWriter file. Normally, these files are expected to have the extension .nwr. Imported NoteWriter files use a sub-class of NoteAbilityPro images that allow only limited editing operations. The available editing options are available in the NoteWriter Controls panel in the Tools menu. Imported NoteWriter files can be printed, saved as PDF through the Print panel, and saved as NoteAbilityPro documents for later printing and editing.

The Print... menu item brings up the standard Print panel so that you can Print, or Save the document as a PDF or EPS file. If you have not yet chosen your print and page settings with the Page Setup panel, your score will be scaled to the reduction size you set up when the document was originally created. For more details on printing refer to the chapter on Printing.

The Print All... menu item brings up the standard Print panel, but rather than printing only one document, it prints all open NoteAbilty documents one after another. You should set the Page Layout on all documents before using this menu item.

The Play Score menu item can be used instead of clicking on the play button on Control Panel. While the score is playing the menu title is changed to "Stop Play" and the menu functions as a stop button. If the Playback map and Tempo map are active, they are used during playback.

The Play Selection menu item can be used to play a group of notes selected with either the Select Image or Select Score tool. The tempo indicated in the Control Panel is used for playback.

The Record To Disk menu item allows you to record your score as an audio file. When selected, a dialog box appears which lets you name the file and choose the audio format. Currently there are 4 audio formats supported:

Of these formats, the first 2 are compressed audio formats which take up approximately 1 Mb of disk space per minute of sounds whereas the last 2 formats are high quality digital audio formats that take up approximately 10 Mb of disk space per minute of sound. All formats can be played by Quicktime Player or by ITunes. The WAVE and AIFF formats should be compatible with all standard audio players and editors.

Once you have named the file and selected the audio format, the score will be played and during playback will be transfered to disk as an audio file. Once the score has finished playing you may open the audio file, or burn it onto a CD using ITunes.

The Record To Disk From Cursor menu item allows you to record your score as an audio file beginning at the measure the Entry Cursor is currently in. The process is the same as that outline above.

See also

© Keith A. Hamel 1998-2005 - All Rights Reserved