Edit Filter / Delete Pages Pane
  1. If the Score Structure panel is not already visible on your screen, choose Score Structure Panel... from the Tools menu to make it visible.
  2. If the Edit Filter / Delete Pages pane (which contains the tabs: Edit Filter, Fill, and Delete Pages) is not visible in the Score Structure Panel, select Edit Filter / Delete Pages from the Available Panes pull-down menu at the top of the Score Structure Panel.
  3. Choose between the three tabs in the Edit Filter / Delete Pages pane to view controls for Edit Filter, Fill, or Delete Page.

Edit Filter Tab

The Edit Filter tab view is used to modify a selected portion of the score to exclude certain images. This allows you to more easily perform editing operations on certain kinds of musical infomration.

To use the Edit Filter, make a selection in the score (using any of the standard selection methods). Then set the filter by clicking on the check boxes in the Edit Filter pane. These settings determine which images will remain selected. All other images will be unselected once you click on the Filter Images button. Although the selection rectangle in the score remains, the actual images selected will be modified to reflect the settings you have made in the Edit Filter tab view.

The first 4 check boxes refer to categories of images that can be retained in the selection (i.e. dynamic markings and crescendi). The last 4 check boxes refer specifically to pitches. The first two of these allow you to retain only certain pitch classes (i.e. pitches in all octaves), and the second two of these allow you to retain only pitches in a specified octave. You can, therefore, restrict a selection either to a specific pitch class or to a pitch in a specific octave. The sliders are used to set the pitch, and the octave number is typed into the octave text box. After clicking on the Filter Images button only the images indicated by your check boxes will continue to be selected.

- Although it is normally possible to select a series of check boxes, some of the filter settings are mutually exclusive (eg. Notes and Rests Only and All Except Notes and Rests). In those cases, it is not possible to select both check boxes. The Clear Checks menu item (in the small pull-down menu located in the top-right corner of this page) is used to turn off all check boxes and thereby clear out the filter.

In the example below, we begin with a selection made around the first two measures of a Chopin prelude.

Next, we make a number of settings in the Edit Filter pane. We set the filter to remove all images except:

Once you click on the Filter Images button the score selection is altered so that only the images you indicated are selected:

You may now perform whatever editing procedure you desire on the remaining pitches. You can drag these images with the mouse, or use andy of the menu or inspector panes editing routines. In this example, the Transposition pane was used to raise the selected notes by a Major second - my apologies to Chopin.

The Edit Filter pane is useful in instances where you want to modify only specific pitches or specific kinds of images. For example, aligning dynamic markings, changing pitches enharmonically, or adding articulations to only certain pitches. In these cases, the Edit Filter is much more efficient than creating a series of selection rectangles using Shift-Selection.

Fill Tab

The Fill Across/Fill Down pane is used for pasting copied material repeatedly along the staves, or down through the staves in the system.

In order to use the Fill Down or Fill Across functions, you must first copy the material you want pasted so that this data is loaded into the copy buffer. Next, place the Entry Cursor at the location you want the first copy of the pasted data to appear. Next set the number of repetitions you want to by adjusting the appropriate slider. Finally, click on either the Fill Down or Fill Across buttons.

The example below demonstrates how to create a score excerpt where all five staves contain the same music. First, enter a line of music, select it by making a rectangle around it with the Selection tool, and copy the passage using the Copy item in the Edit menu:

Next, place the Entry Cursor on the second staff of the system (on the beat position you want the music to begin at - i.e. immediately beneath the first note of the passage). Set the number of staves you want pasted onto (4 in this case). Finally, click on the Fill Down button and the following score will be created:

Similarly, Fill Across also requires that the music data to be pasted is first entered, selected, and copied. The music data can cover as many staves as you want. In the example below, a short passage on two staves is entered, selected with the Selection tool, and copied.

The Entry Cursor is placed on the first staff and on the beat position immediately following the passage. Next, the number of repetitions is set using the slider in the Fill Across box. FInally, the Fill Across button is clicked. The resulting score is:

- The Fill Down operation can be used when a series of staves has the same rhythm but different pitches. In this situation it is probably faster to paste the data into all the staves (using Fill Down and adjust the incorrect notes.)

Delete Page Tab

The Delete Last Page pane is used to remove extra pages that have been added to the end of your document and are no longer needed.

The last page number and last measure number are displayed when the tab view is activated, and these values are updated every time you remove a page. To remove a page, click on the Delete Last Page button. Since this operation cannot be undone, a panel appears to ensure that you really do want to delete this page. Deleting pages is sometimes necessary because NoteAbilityPro automatically adds new pages as needed or when certain formatting operations take place. For example if you have two pages each with 5 systems on a page and 5 measures per system and you change all systems to have only 3 measures, NoteAbilityPro will wrap the existing measures onto new pages and you will now have 4 pages with 15 measures per page.

- Deleting extra pages is normally left until the document is finished and all measure and system formatting has been done.

- You can delete pages in the middle of your score by using the Delete Page item from the Format menu.

Menu items

The pull down menu located at the top-right corner of this pane contains menu items related to the Edit Filter.

See also

© Keith A. Hamel 1998-2005 - All Rights Reserved